解决代理中的限制错误

本文介绍限制错误的原因,以及如何在与 Copilot Studio 代理交互时克服这些错误。

症状

与 Copilot Studio 代理交互时,用户可能会收到以下错误消息:

  • GenAISearchandSummarizeRateLimitReached:“已达到搜索和汇总的使用限制。 请稍后再试。”

  • GenAIToolPlannerRateLimitReached:“已达到生成业务流程的使用限制。 请稍后再试。”

  • OpenAIRateLimitReached:“你的代理达到了生成答案响应的最大数量。

原因

Copilot Studio 的默认约束适用于限制消息发送到代理的频率的代理。 这些约束主要是为了防止意外的使用激增,否则可能会影响应用程序的功能。

对于使用生成 AI 和主题业务流程生成的消息,配额会限制每个 Dataverse 环境每小时和分钟可以发送的请求数。 达到限制后,当用户尝试发送新消息时,会将一条消息发送到与代理交互。

解决方案

如果由于达到代理速率限制而看到这些错误消息,请查看许可模型,以确定应获取多少额外的容量包来涵盖消耗配额,或者是否应更改为即用即付模型。 有关配额和租户计费容量的详细信息,请参阅 配额和限制

提高速率限制

另一种选择是联系Microsoft支持部门并请求提高速率限制。 但是,此选项不保证授予异常或增加。 每个请求都会根据资格和当前许可进行评审和批准。 仅当环境为 Copilot Studio 提供即用即付时,才会评估请求。 仅基于消息的功能运行的环境不符合考虑条件。

有关 Copilot Studio 代理的生成答案的速率限制和消耗的详细信息,请查看以下文档: