本文介绍如何识别并解决“PublicIPCountLimitReached”错误。 尝试创建、更新或升级 Azure Kubernetes 服务 (AKS) 群集时,会发生此错误。 此错误也可能由触发创建公共 IP 地址的任何其他作(例如部署 Kubernetes 服务类型公共负载均衡器)引起。
症状
AKS 群集的创建、更新、升级或其他操作触发了公共 IP 地址的创建,例如部署具有公共负载均衡器的 Kubernetes 服务时,操作失败并返回“PublicIPCountLimitReached”错误消息。
原因
如果已达到订阅允许的最大公共 IP 地址数,则会发生此错误。 限制因订阅类型而异。 有关公共 IP 地址限制的详细信息,请参阅 此详细指南。
解决方案
若要增加订阅的公共 IP 限制或配额,请执行以下步骤:
导航到 Azure 门户,然后选择要执行操作的订阅。
在 “设置” 部分中,选择“ 使用情况 + 配额”。 将 提供程序 设置为 网络,并根据需要按 AKS 群集的区域进行筛选。
找到 公共 IP 地址 记录。 在同一行中,选择“ 创建新的支持请求 ”按钮。
在 “新建支持请求 ”页上,指定所需的新限制,然后按照说明创建支持请求。
配额更改生效后,请重试第一次触发“PublicIPCountLimitReached”错误的操作。