Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
I den här artikeln beskrivs hur du identifierar och löser det LinkedAuthorizationFailed fel som uppstår när du försöker skapa och distribuera ett AkS-kluster (Microsoft Azure Kubernetes Service).
Symptome
När du försöker skapa ett AKS-kluster får du följande felmeddelande:
Det gick inte att samsynkronisera VNet.
Information: Det gick inte att försöka igen med VNetReconciler:
Kategori: ClientError; Underkod: LinkedAuthorizationFailed;
Beroende: Microsoft.Network/virtualNetworks; OriginalError: Code="LinkedAuthorizationFailed"
Message="Klienten '12345678-1234-1234-1234-123456789098' med objekt-ID '123456789-1234-1234-1234-1234567890987' har behörighet att utföra åtgärden 'Microsoft.Network/virtualNetworks/write' på omfånget '/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyRG_westeurope/providers/Microsoft.Network/virtualNetworks/aks-vnet'; dock inte för att utföra åtgärden 'Microsoft.Network/ddosProtectionPlans/join/action' på de länkade omfången '/subscriptions/<subscription-id-guid>/resourceGroups/ddos-protection-plan-rg/providers/Microsoft.Network/ddosprotectionplans/upmddosprotectionplan' eller så är de länkade omfången ogiltiga."
AKSTeam: Nätverk, Återställningsbar: false.
Orsak
Ett tjänsthuvudnamn har inte behörighet att använda en resurs som krävs för att skapa kluster.
Lösning
Bevilja tjänstens huvudansvarig behörighet att använda resursen som nämns i felmeddelandet. Exempelutdata i avsnittet "Symptom" innehåller följande information.
| Objekt | Värde | 
|---|---|
| Service Principal | 12345678-1234-1234-1234-123456789098 | 
| Resurs | /subscriptions/<subscription-id-guid>/resourcegroups/ddos-protection-plan-rg/providers/microsoft.network/ddosprotectionplans/upmddosprotectionplan | 
| Verksamhet | Microsoft.Network/DDoS-skyddsplaner/join/action | 
Mer information om hur du beviljar behörigheter till tjänstens huvudnamn finns i Tilldela Azure-roller med hjälp av Azure Portal.
Mer information
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp, skapa en supportförfrågan, eller fråga Azures community-support. Du kan också lämna produktfeedback till Azure feedback-community.