Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
I den här artikeln beskrivs hur du identifierar och löser det InvalidParameter fel som uppstår när du försöker skapa och distribuera ett AkS-kluster (Microsoft Azure Kubernetes Service).
Förutsättningar
- 
              Azure CLI, version 2.0.81 eller senare. Om Azure CLI redan är installerat kan du hitta versionsnumret genom att köra 
az --version. 
Symptome
När du skapar ett AKS-kluster verifieras vanligtvis de angivna konfigurationerna innan klustret skapas. I sällsynta fall godkänns dock verifieringen av en parameter innan AKS-klustret skapas men orsakar fel när resurserna för klustret skapas. Fel som är relaterade till ogiltiga parametrar kan likna följande exempel:
Scenario: Den valda VM-storleken är inte tillgänglig
Code="InvalidParameter" Message="**The requested VM size Standard_D4s_v3 is not available in the current region. The sizes available in the current region are: ExtraSmall_Internal, Small_Internal, Medium_Internal, Large_Internal, ExtraLarge_Internal, Standard_DC2as_v5, Standard_DC4as_v5, Standard_DC8as_v5, Standard_DC16as_v5, Standard_DC32as_v5, Standard_DC48as_v5, Standard_DC64as_v5, Standard_DC96as_v5, Standard_DC2ads_v5, Standard_DC4ads_v5, Standard_DC8ads_v5, Standard_DC16ads_v5, Standard_DC32ads_v5, Standard_DC48ads_v5, Standard_DC64ads_v5, Standard_DC96ads_v5, Standard_EC2as_v5, Standard_EC4as_v5, Standard_EC8as_v5, Standard_EC16as_v5, Standard_EC20as_v5, Standard_EC32as_v5, Standard_EC48as_v5, Standard_EC64as_v5, Standard_EC96as_v5, Standard_EC96ias_v5, Standard_EC2ads_v5, Standard_EC4ads_v5, Standard_EC8ads_v5, Standard_EC16ads_v5, Standard_EC20ads_v5, Standard_EC32ads_v5, Standard_EC48ads_v5, Standard_EC64ads_v5, Standard_EC96ads_v5, Standard_EC96iads_v5.\r\nFind out more on the available VM sizes in each region at <https://aka.ms/azureregions>." Target="vmSize"Scenario: Klusternamn är inte tillgängliga eller står i konflikt med reserverade Azure-värden
Exempel 1
Code="InvalidParameter" Message="The value of parameter name is invalid. Error details: "omsagent-aks-dev-microsoft" managed cluster name is invalid because 'MICROSOFT' and 'WINDOWS' can't be used as either a whole word or a substring in the name.. Please see https://aka.ms/aks-naming-rules for more details."Exempel 2
Message="The value of parameter name is invalid. Error details: "login" managed cluster name is invalid because 'LOGIN' and 'XBOX' can't be used at the start of a resource name, but can be used later in the name.. Please see https://aka.ms/aks-naming-rules for more details."Exempel 3
Message=" The value of parameter name is invalid. Error details: "azure" managed cluster name is invalid because it is reserved.. Please see https://aka.ms/aks-naming-rules for more details. Target: name"
Orsak
Det här problemet beror på att något av följande villkor är sant:
- Azure Virtual Machine SKU är inte tillgängligt i den valda regionen.
 - Tjänstens huvudnamn är ogiltigt.
 - Ett virtuellt nätverk, undernät eller routningstabell är ogiltigt.
 - En Azure CLI-parameter är ogiltig.
 - Värdet för parameternamnet är inte tillgängligt eller reserverat av Azure.
 
Det kan också finnas andra orsaker till att det inte gick att skapa klustret.
Lösning
I följande tabell följer du länken för lämpligt felsökningssteg.
| Felsökningssteg | Referenslänk | 
|---|---|
| Kontrollera om SKU:n är tillgänglig | Åtgärda fel med otillgänglig SKU | 
| Kontrollera att tjänstens huvudnamn är giltigt | Service-principaler tillsammans med AKS | 
| Kontrollera att alla kommandon som användes för att skapa klustret är giltiga | az aks (Azure CLI-referens) | 
| Kontrollera att alla anpassade nätverksresurser som användes för att skapa klustret är giltiga | Konfigurera Azure CNI-nätverk i AKS och Anpassa klusterutgående trafik med en användardefinierad rutt | 
| Undvik att använda otillgängliga eller Azure-reserverade värden för namn | Se de felmeddelanden som tillhandahålls | 
Mer information
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp, skapa en supportförfrågan, eller fråga Azures community-support. Du kan också lämna produktfeedback till Azure feedback-community.