Dela via


CreateOrUpdateVirtualNetworkLinkFailed-fel vid uppdatering eller uppgradering av ett AKS-kluster

Den här artikeln innehåller en lösning på felkoden "CreateOrUpdateVirtualNetworkLinkFailed" som inträffar när du försöker uppdatera eller uppgradera ett AkS-kluster (Microsoft Azure Kubernetes Service).

Förutsättningar

Azure CLI

Symptome

En AKS-klusteruppdatering eller uppgraderingsåtgärd misslyckas och returnerar följande felmeddelande:

Kod: CreateOrUpdateVirtualNetworkLinkFailed – Underkod: BadRequest

Meddelande: Det gick inte att sammanställa privat DNS

Information: Det gick inte att skapa eller uppdatera länken till det virtuella nätverket. Prenumeration: <SubscriptionID>; resursgrupp: <RGName>; privat dns-zon: <GUID.privatelink>.<region.azmk8s.io>; länk till virtuellt nätverk: <VNET_Link>.

Meddelande: Ett virtuellt nätverk kan inte länkas till flera zoner med överlappande namnområden. Du försökte länka det virtuella nätverket med '<GUID>.privatelink.<region>.azmk8s.io' och '<GUID>.privatelink.<region>.azmk8s.io'-zoner.

Orsak

Det här felet inträffar i det här scenariot:

  • Du kopplar bort den ursprungliga privata DNS-zonen (Domain Name System) för AKS-klustret.
  • Du länkar en privat DNS-zon som har samma namn som den ursprungliga zonen men som finns i en annan resursgrupp eller prenumeration.

Därför visas samma privata DNS-zonnamn "<GUID.privatelink>.<region.azmk8s.io>" i felmeddelandet. Den första är den nya zonen i den nya resursgruppen eller prenumerationen, medan den andra är den ursprungliga zonen som skapats med AKS-klustret.

Lösning

Följ dessa anvisningar för att lösa problemet:

  1. Ta bort länken mellan AKS-klustrets virtuella nätverk (VNET) och den privata DNS-zon som skapats i fel resursgrupp eller prenumeration.

  2. Uppdatera klustret genom att köra följande kommando:

    az aks update  -n <myAKSCluster> -g <myResourceGroup>
    

    Kommandoutdata bör visa klustrets ProvisioningState som Running.

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp, skapa en supportförfrågan, eller fråga Azures community-support. Du kan också lämna produktfeedback till Azure feedback-community.