Dela via


Felsöka fel när du skapar eller växlar till ett AKS-automatiskt kluster

Den här artikeln innehåller vägledning för att lösa fel som uppstår när du skapar eller växlar till ett automatiskt Azure Kubernetes Service-kluster (AKS).

Fel 1: AKS Automatic kunde inte hitta en lämplig VM-storlek.

Symptoms

När du försöker skapa ett AKS-automatiskt kluster får du följande felmeddelande:

AKS Automatic kunde inte hitta en lämplig VM-storlek. Prenumerationen kanske inte har den kvot på 16 vCPU:er som krävs, kan ha begränsningar eller plats $location kanske inte stöder tre tillgänglighetszoner för följande VM-storlekar: "standard_d4lds_v5,standard_d4ads_v5,standard_d4ds_v5,standard_d4d_v5,standard_d4d_v4,standard_ds3_v2,standard_ds12_v2,standard_d4alds_v6,standard_d4lds_v6,standard_d4alds_v5". Begär en viss kvot för någon av dessa vm-kandidatstorlekar i målregionen eller ange uttryckligen en vm-storlek med tillräcklig kvot via --node-vm-size.

Orsak

Det här felmeddelandet anger att något av flera problem finns: Prenumerationen tillhandahåller inte en tillräckligt stor kvot med virtuella processorer som tilldelats virtuella datorer eller platsen där klustret skapas har inte stöd för tre tillgänglighetszoner. Utan en tillräcklig kvot kan systempoolen för AKS Automatic-klustret inte skapas.

Lösning

Lös det här felet genom att prova någon av följande korrigeringar:

  • Öka den regionala vCPU-kvoten för en av de listade vm-storlekarna.
  • Distribuera klustret i en annan region som har en befintlig kvot som rymmer en av dessa VM-storlekar.
  • Om du använder Azure CLI anger du vm-storleken med hjälp --vm-sizesav .

Fel 2: Automatisk SKU stöds inte i den här regionen.

Symptoms

När du försöker skapa ett AKS-automatiskt kluster får du följande felmeddelande:

Automatisk SKU stöds inte i den här regionen.

Orsak

Det här felet anger att du inte kan skapa AUTOMATISKA AKS-kluster i regioner där API Server VNet-integrering inte är allmänt tillgänglig.

Lösning

Skapa kluster i regioner där API Server VNet-integrering är allmänt tillgänglig.

Fel 3: Det hanterade klustret "Automatisk" SKU bör ange taint "CriticalAddonsOnlyNoSchedule" för systemnodpoolen.

Symptoms

När du tar bort tainten "CriticalAddonsOnlyNoSchedule" från systemnodpoolen i ett AKS Automatic-kluster får du följande felmeddelande:

SKU:n för det hanterade klustret "Automatisk" ska ange taint "CriticalAddonsOnlyNoSchedule" för systemnodpoolen.

Orsak

Det är inte tillåtet att ta bort tainten CriticalAddonsOnlyNoSchedule från systemnodpoolen i ett AKS Automatic-kluster.

Lösning

Det här beteendet är avsiktligt. "CriticalAddonsOnlyNoSchedule" behåller systemtillägg som körs på systemnodpoolen i stället för på användarnodpoolen.

Symptoms

När du försöker uppdatera ett befintligt AKS-kluster från SKU:n "Base" till SKU:n "Automatic" visas följande felmeddelande:

SKU:n för det hanterade klustret "Automatisk" ska aktivera funktionen $feature_name med rekommenderade värden. Funktionsnamnet varierar beroende på vilken funktion som inte har aktiverats.

Orsak

När du uppdaterar ett befintligt AKS-kluster från "Base" till "Automatic" måste alla AUTOMATISKA AKS-funktioner först aktiveras i basklustret.

Lösning

Aktivera den specifika funktion som nämns i felmeddelandet innan du uppdaterar klustret till "Automatisk". Några av de nödvändiga funktionerna omfattar, men är inte begränsade till, följande funktioner:

Fel 5 – SKU:n för det hanterade klustret "Automatisk" bör använda standardnivån.

Symptoms

När du försöker uppdatera ett befintligt AKS-kluster från SKU:n "Base" till SKU:n "Automatic" visas följande felmeddelande:

SKU:n för det hanterade klustret "Automatisk" bör använda Standardnivå.

Orsak

AKS Automatic erbjuder endast en nivå: Standard.

Lösning

Innan du uppdaterar ett befintligt AKS-kluster från "Base" till "Automatic" kontrollerar du att det är inställt på standardnivån.

Ansvarsfriskrivning för information från tredje part

Produkter från tredje part som beskrivs i den här artikeln tillverkas av företag som är oberoende av Microsoft. Microsoft ger ingen garanti, uttrycklig eller underförstådd, angående prestandan eller tillförlitligheten hos dessa produkter.

Kontakta oss för att få hjälp

Om du har frågor eller behöver hjälp, skapa en supportförfrågan, eller fråga Azures community-support. Du kan också lämna produktfeedback till Azure feedback-community.