Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
I den här artikeln beskrivs hur du löser ett InsufficientSubnetSize fel som uppstår när du försöker distribuera ett AkS-kluster (Microsoft Azure Kubernetes Service) som använder avancerade nätverk. Den här artikeln gäller både Kubernetes-kluster och CNI-kluster (Azure Container Networking Interface).
Symptom
Felet InsufficientSubnetSize uppstår under någon av följande åtgärder. Det här felet påträffas också i AKS-diagnostik, som proaktivt identifierar problem som en otillräcklig undernätsstorlek.
Åtgärd 1: Skala ett AKS-kluster eller en AKS-nodpool
| Klustertyp | Symptom: Antalet kostnadsfria IP-adresser i undernätet är mindre än... |
|---|---|
| Kubenet | Antalet nya noder som begärs. |
| Azure CNI | Antalet nya noder som begärs gånger värdet för nodpoolen i parametern --max-pod . |
| Azure CNI-överlägg | Antalet nya noder som begärs. (I de nodpooler som använder autoskalning är antalet noder värdet i parametern --max-count .) |
Åtgärd 2: Uppgradera ett AKS-kluster eller en AKS-nodpool
| Klustertyp | Symptom: Antalet kostnadsfria IP-adresser i undernätet är mindre än... |
|---|---|
| Kubenet | Antalet buffertnoder som måste uppgraderas. |
| Azure CNI | Antalet buffertnoder som måste uppgraderas gånger värdet för nodpoolen i parametern --max-pod . |
| Azure CNI-överlägg | Antalet buffertnoder som måste uppgraderas. (I de nodpooler som använder autoskalning är antalet noder värdet i parametern --max-count .) |
Som standard anger ett AKS-kluster ett högsta ökningsvärde (uppgraderingsbuffert) på ett (1). Du kan dock anpassa det här uppgraderingsbeteendet genom att ange det maximala överspänningsvärdet för en nodpool. Den här åtgärden ökar antalet tillgängliga IP-adresser som krävs för att slutföra en uppgradering.
Åtgärd 3: Skapa ett AKS-kluster eller lägga till en AKS-nodpool
| Klustertyp | Symptom: Antalet kostnadsfria IP-adresser i undernätet är mindre än... |
|---|---|
| Kubenet | Antalet noder som begärs. |
| Azure CNI | Antalet noder som begärs gånger värdet för nodpoolen i parametern --max-pod . |
| Azure CNI-överlägg | Antalet noder som begärs. (I de nodpooler som använder autoskalning är antalet noder värdet i parametern --max-count .) |
Orsak
Ett undernät som används för ett kluster har inte längre tillgängliga IP-adresser inom CIDR-adressutrymmet (Classless Inter-Domain Routing) för lyckad resurstilldelning.
| Klustertyp | Krav |
|---|---|
| Kubenet | Tillräckligt med IP-utrymme för varje nod i klustret |
| Azure CNI | Tillräckligt med IP-utrymme för varje nod och podd i klustret |
| Azure CNI-överlägg | Tillräckligt med IP-utrymme för varje nod i klustret |
Läs mer om utformningen av Azure CNI för att tilldela IP-adresser till poddar.
Lösning
Det går för närvarande inte att uppdatera ett undernäts CIDR-adressutrymme i en befintlig nodpool. Följ dessa steg för att migrera dina arbetsbelastningar till en ny nodpool i ett större undernät:
Skapa ett undernät i det virtuella klustrets nätverk som innehåller ett större CIDR-adressintervall än det befintliga undernätets. Information om hur du storleksanpassar undernätet tillräckligt för klustret finns i Planera IP-adressering för klustret.
Skapa en nodpool i det nya undernätet genom att köra kommandot az aks nodepool add tillsammans med parametern
--vnet-subnet-id.Migrera dina arbetsbelastningar till den nya nodpoolen genom att tömma noderna i den gamla nodpoolen. Information om hur du tömmer AKS-arbetsnoder på ett säkert sätt finns i Töm en nod på ett säkert sätt.
Ta bort den ursprungliga nodpoolen genom att köra kommandot az aks nodepool delete .
Ansvarsfriskrivning för tredje part
Microsoft tillhandahåller kontaktinformation från tredje part som hjälper dig att hitta ytterligare information om det här ämnet. Denna kontaktinformation kan ändras utan föregående meddelande. Microsoft garanterar inte att kontaktinformation från tredje part är korrekt.
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.