Anteckning
Åtkomst till den här sidan kräver auktorisering. Du kan prova att logga in eller ändra kataloger.
Åtkomst till den här sidan kräver auktorisering. Du kan prova att ändra kataloger.
I den här artikeln beskrivs hur du löser felet "tidsgränsen för kontexten överskreds" som inträffar när du försöker hämta en avbildning från Microsoft Azure Container Registry.
Symptom
När du försöker hämta en avbildning från containerregistret får du följande felmeddelande:
Hämta "https://< container-registry-name.azurecr.io/v2/>": tidsgränsen för kontexten har överskridits
Orsak
Enheten kände inte igen namnet på containerregistrets inloggningsserver.
Lösning
Kontrollera att namnet på containerregistrets inloggningsserver kan matchas. Om du vill testa om enheten kan matcha inloggningsservern i containerregistret manuellt kör du följande nslookup-kommando :
nslookup <container-registry-name>.azurecr.io
Om namnet inte löstes kan du försöka isolera problemet med hjälp av Azure Domain Name Service (DNS). Kör följande nslookup kommando för att försöka matcha inloggningsservern för containerregistret via Azure DNS IP-adressen (168.63.129.16):
nslookup <container-registry-name>.azurecr.io 168.63.129.16
Om Azure DNS löser namnet kontrollerar du enhetens DNS-inställningar. Om enheten använder en anpassad DNS-server (inte Azure DNS) kontrollerar du att den anpassade DNS-servern kan matcha namnet på containerregistrets inloggningsserver.
Kontakta oss för att få hjälp
Om du har frågor eller behöver hjälp skapar du en supportförfrågan eller frågar Azure community support. Du kan också skicka produktfeedback till Azure-feedbackcommunityn.