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This article provides steps to resolve the "Generative AI not available error message" in Copilot Studio agents.
Symptoms
Users receive the following error message when interacting with the Copilot Studio agent:
"Error message: Features with generative AI are not available in your environment. Error code: GenerativeAINotAvailable"
Agent makers also receive the following warning message in Copilot Studio in the Generative AI settings page:
"Features with generative AI are not available in your environment. Please contact your admin."
Cause
Generative AI features aren't accessible in all regions and languages. In some cases, data might need to move outside the region for these features to be available or to rely on other Microsoft services outside the environment region.
If data movement across regions is disabled in an environment that needs it for generative AI features, then these features aren't available for agents. If the environment requires cross-geo calls, users see an error message when they try to use generative AI tools or orchestration.
Solution
To fix this error, enable data movement across regions for the environment. Another option is to change your agent behavior to avoid using generative AI features for responses or topic orchestration.
Enable generative AI features:
Access the Power Platform Admin Center.
Select the respective environment.
Under Generative AI features, select Edit.
Enable Move data across regions.
Select Save.
If you can't turn on this setting, you need to adapt your agent's behavior. Turn off generative AI features (like generative orchestration, web search, AI general knowledge, and AI tools) to prevent users from seeing this message when they chat with your agent.
Related information
To understand what features and regions require data movement, review the following information: