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Troubleshoot errors when creating or switching to an AKS Automatic cluster

This article provides guidance for resolving errors that occur when you create or switch to an Azure Kubernetes Service (AKS) Automatic cluster.

Error 1: AKS Automatic could not find a suitable VM size.

Symptoms

When you try to create an AKS Automatic cluster, you receive the following error message:

AKS Automatic could not find a suitable VM size. The subscription may not have the required quota of '16' vCPUs, may have restrictions, or location $location may not support three availability zones for the following VM sizes: 'standard_d4lds_v5,standard_d4ads_v5,standard_d4ds_v5,standard_d4d_v5,standard_d4d_v4,standard_ds3_v2,standard_ds12_v2,standard_d4alds_v6,standard_d4lds_v6,standard_d4alds_v5'. Please request some quota for one of these candidate vm sizes in the target region or explicitly specify a vm-size with sufficient quota via --node-vm-size.

Cause

This error message indicates that any of several problems exists: The subscription doesn't provide a sufficiently large quota of vCPUs assigned to virtual machines (VMs) or the location where the cluster is being created does not support three availability zones. Without a sufficient quota, the system pool for the AKS Automatic cluster can't be created.

Solution

To resolve this error, try one of the following fixes:

  • Increase the regional vCPU quota for one of the listed vm sizes.
  • Deploy the cluster in a different region that has an existing quota that accommodates one of these VM sizes.
  • If you're using Azure CLI, specify the VM size by using --vm-sizes.

Error 2: Automatic SKU is not supported in this region.

Symptoms

When you try to create an AKS Automatic cluster, you receive the following error message:

Automatic SKU is not supported in this region.

Cause

This error indicates that you can't create AKS Automatic clusters in regions where API Server VNet Integration isn't generally available.

Solution

Create the clusters in regions where API Server VNet Integration is generally available.

Error 3: Managed cluster 'Automatic' SKU should set taint 'CriticalAddonsOnlyNoSchedule' for the system node pool.

Symptoms

When you remove the 'CriticalAddonsOnlyNoSchedule' taint from the system node pool of an AKS Automatic cluster, you receive the following error message:

Managed cluster 'Automatic' SKU should set taint 'CriticalAddonsOnlyNoSchedule' for the system node pool.

Cause

Removing the 'CriticalAddonsOnlyNoSchedule' taint from the system node pool of an AKS Automatic cluster is not allowed.

Solution

This behavior is by design. 'CriticalAddonsOnlyNoSchedule' keeps system add-ons running on the system node pool instead of on the user node pool.

Symptoms

When you try to update an existing AKS cluster from the "Base" SKU to the "Automatic" SKU, you receive the following error message:

Managed cluster 'Automatic' SKU should enable $feature_name feature with recommended values. The feature name will vary based on the feature that has not been enabled.

Cause

When you update an existing AKS cluster from "Base" to "Automatic," all AKS Automatic features must first be enabled on the Base cluster.

Solution

Enable the specific feature that's mentioned in the error message before you update the cluster to "Automatic." Some of the required features include, but aren't limited to, the following features:

Error 5 - Managed cluster 'Automatic' SKU should use Standard tier.

Symptoms

When you try to update an existing AKS cluster from the "Base" SKU to the "Automatic" SKU, you receive the following error message:

Managed cluster 'Automatic' SKU should use Standard tier.

Cause

AKS Automatic offers only one tier: Standard.

Solution

Before you update an existing AKS cluster from "Base" to "Automatic," make sure that it's set to the "Standard" tier.

Third-party information disclaimer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.