Note
Access to this page requires authorization. You can try signing in or changing directories.
Access to this page requires authorization. You can try changing directories.
Symptoms
A non-delivery report (NDR) is returned with error code 554 5.2.2 when sending emails to a mail-enabled public folder:
The recipient's mailbox is full and can't accept messages now. Please try resending this message later or contact the recipient directly.
Diagnostic information for administrators
Remote Server returned '554 5.2.2 mailbox full;
STOREDRV.Deliver.Exception:QuotaExceededException.MapiExceptionQuotaExceeded'
Cause
This issue occurs when any of these conditions is met:
- The organization's default public folder post quota (
DefaultPublicFolderProhibitPostQuota) is reached. - The individual public folder post quota (
PublicFolderProhibitPostQuota) is reached. - The Content Public Folder mailbox hosting the mail-enabled public folder reaches its quota.
Resolution
Here's how to identify which quota is reached and take corrective steps:
Step 1: Check individual public folder quota
Check the value of
TotalItemSizefor the affected mail-enabled public folder:Get-PublicFolderStatistics \pfname | FL TotalItemSizeCheck if the value of
TotalItemSizereaches or exceeds the value ofProhibitPostQuota.Get-PublicFolder \pfname | FL *quota*If that's the case, increase the
ProhibitPostQuotavalue of that mail-enabled public folder or set it to Unlimited.Note
If the default value of
prohibitpostquotais set to Unlimited, the value that was configured forDefaultPublicFolderProhibitPostQuotaat the organization level applies. If thePublicFolderProhibitPostQuotavalue has been configured on the public folder, this value will take precedence over the value set at the organization level.For more information, read Understanding modern public folder quotas.
Check if the value of
TotalItemSizeexceeds the value ofDefaultPublicFolderProhibitPostQuota:Get-OrganizationConfig | FL *quota*A
TotalItemSizelarger thanDefaultPublicFolderProhibitPostQuotaprevents mail-enabled public folders from accepting new emails.
Here are two ways to resolve this issue:
Increase the
ProhibitPostQuotaof the public folder at the user level if there are only a few affected public folders.Set-PublicFolder \pfname -ProhibitPostQuota 5GB -IssueWarningQuota 4GBIncrease the
DefaultPublicFolderProhibitPostQuotafor all public folders at the organization level.Set-OrganizationConfig -DefaultPublicFolderProhibitPostQuota 5GB -DefaultPublicFolderIssueWarningQuota 4GB
Note
Avoid a large increase of the individual public folder Prohibitpostquota. Setting this value too high will impact the auto-split process negatively.
If this quota is exceeded, proceed to the next step.
Step 2: Check the content public folder mailbox quota
If the public folder exceeds the individual or organizational quota as shown in Step 1, check if the public folder mailbox hosting the public folder content exceeds its quota.
Find the content public folder mailbox's name for the mail-enabled public folder:
Get-PublicFolder \pfname |FL name, *content*Check the value of
TotalItemSizefor the content public folder mailbox:Get-MailboxStatistics pfmbx | FL TotalItemSizeCheck if the value of
TotalItemSizeexceeds the value ofProhibitSendRecieveQuota:Get-Mailbox -PublicFolder pfmbx | FL *quota*
When a quota is reached, the auto-split process should create a new public folder mailbox and move some of that content to a newly created auto-split mailbox. To check that, run this command:
Get-PublicFolder \pfname |Ft name, *content*
For more information, read the following Blog articles:
- How Exchange Online automatically cares for your public folder mailboxes (via AutoSplit)
- Public Folders and Exchange Online
If the auto-split process failed to create a new mailbox, please submit a support request to Microsoft Support for further assistance.